The Warp Room

Full Version: Steam Overlay stopped working after mods **SOLVED!**
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The mods I currently have installed are:

• Skip Activision Boot Up Logo - https://gamebanana.com/gamefiles/7140
• Original Font HUD (Basic) - https://gamebanana.com/guis/34311
• N. Sane Patcher- https://www.nexusmods.com/crashbandicoot...gy/mods/12
• 3D Vision Fix - https://gamebanana.com/tools/6495 (<----- Breaks Steam Overlay)

I am not sure which mod caused Steam Overlay to break but I first thought the custom Pixelvision2 Skin for the client caused it, so I disabled it and no luck. I tried other Steam games with custom client skin on and off and the Overlay works in other games. I checked and Steam Overlay is set to on in N. Sane Trilogy, it was working before but when I started modding the game the Steam Overlay doesn't appear anymore. I still unlock achievements but there is no Overlay notification telling me in game what I unlocked, the Steam chat doesn't appear either.
My guess is the 3D Vision mod, try disabling that. I imagine it could be causing a conflict with how Steam hijacks the renderer.
Yep, that was the right guess. I deleted the 3D Vision mod files and now Steam Overlay works again! Thanks. Big Grin
I don't have 3D Vision hardware so I've never tried that mod, but it probably uses DLL injection, right? A lot of the time mods that use DLL injection to hook into a game's renderer inadvertently prevent Steam from doing the very same thing to display it's in-game overlay. An early version of Dragon Quest XI's Orchestral Overhaul Mod piggybacked off another generic Unreal graphics mod which had the same problem.
Yes it does use DLL injection, most of the files have DLL format.